MW3 Dedicated Server Running OK- Cant connect from LAN!!

PeKKeR

Junior Member
Joined
Mar 31, 2009
Likes
0
#1
Greetings

So i have managed to setup my own MW3 Dedi server on a server here in the office, viewable from the steam server list...everybody from the internet can connect on it just fine.... no complaints...

HOWEVER , im trying to connect to my dedicated server from my laptop with is in the same LAN, same switch even , i can see the server in the LAN browser...the game starts , logs in online and stucks at CONNECTING .... !!!!

everybody connects on my server except me!! and im in the same LAN!
all firewalls are off...

any ideas?

SOF
 

zeroy

Senior Member
Joined
Oct 20, 2004
Likes
2
Location
Louth, Ireland
#2
I would still think Firewall is an issue here. Are those other PCs on the Internet also or LAN only? Seeing how bad the dedicated server setup is for MW3 i wouldnt be surprised is Internet access is required even for LAN play...
 
Last edited:

PeKKeR

Junior Member
Joined
Mar 31, 2009
Likes
0
#3
The other PCs are in the Internet, and basically the server is a proper dedicated server.

in the console when i load the server is gives me both IPs of the server - internal and external ..so it means that it binds to both ..

my pc can connect to any other dedicated server in the list , except to my one..
 

vampiejay

Senior Member
Joined
May 7, 2007
Likes
0
#4
this could be down to router or routing issues i have issue connecting to my web server using my external ip i have to use the local host or the internal ip as my router denies access this way.
 

PeKKeR

Junior Member
Joined
Mar 31, 2009
Likes
0
#6
Dedicated server is set to 2 , although i also tried changing it to 1 to see if it connect but it still doesnt.Btw im using the internal IP to connect because the server and client are both in the same LAN..the router doesnt get involved.

It doesnt even query the server for info...server times out !

anyway its a stupid problem ..doesnt make sense...i used to have many dedicated servers like this and never had problems...im fed up..
 

vampiejay

Senior Member
Joined
May 7, 2007
Likes
0
#7
the internal ip could be the issue then as the server is set to the external ip for the world to see in the browser but once you try to connect then it will use external ip and your router may refuse connection because of it
 

PeKKeR

Junior Member
Joined
Mar 31, 2009
Likes
0
#8
you could be right. i will try to set a static translation for the external ip to point to the internal ip so that it avoids the router

wil let you know

thx

SOF
 

PeKKeR

Junior Member
Joined
Mar 31, 2009
Likes
0
#9
Nope nothing helped!

i even run the server from another machine, and also used the dedicated=1 option and it still cant connect!! this is crazy...
 

Kadaro

Junior Member
Joined
Nov 9, 2009
Likes
0
#10
Turn OFF upnp in your router. If you need ports open for the server, define them manually in your routers port forwarding.

There might be a static route you can add, but I solved this turning upnp OFF.
You connect from LAN side, public connects from server browser side.
 
Top Bottom