PDA

View Full Version : CoD4 Linux Server - Can't Start


will808
12-22-2007, 12:44 PM
Hi,

I'm trying to setup a CoD4 dedicated server on Xubuntu 7.10 and am having a few problems getting the executables to execute.

I've followed the instructions and:

[1] Copied the contents of Setup/data/* into a directory on the server

[2] Unpacked the .bz2 containing the linux binaries as directed.

[3] Created a user for running the server and changed the owner and group of all the CoD4 files to that user.

When I run the "./cod4-lnxded" command to start the server, I get a message:


exec: 50: ./cod4_lnxded-bin: not found


The referenced file is present though. I've looked at line 50 in the cod4-lnxded file, and the few lines around it:


45 # Let's boogie!
46 if [ -x "${COD4_DATA_PATH}/cod4_lnxded-bin" ]
47 then
48 cd "${COD4_DATA_PATH}/"
49 exec "./cod4_lnxded-bin" $*
50 fi
51 echo "Couldn't run Call of Duty 4 server (cod4_lnxded-bin). Is
52 COD4_DATA_PATH set?"
53 exit 1


I've also had a problem trying to run the Punkbuster executable - the commands don't result in any error messages, but the installer just doesn't run. I think there must be some issue which is causing the executables not to execute.

Can anybody make any suggestions? I think it's probably something very simple and stupid that I have done / not done...

Scrapie
12-22-2007, 06:12 PM
have u setted premissions for the bins? chmod 755

maimedwabbit
12-22-2007, 07:48 PM
When I run the "./cod4-lnxded" command to start the server, I get a message:
Also not sure if its a typo but your command should be "./cod4_lnxded" not "./cod4-lnxded"

will808
12-23-2007, 01:28 AM
Thanks for the replies guys - the bin's are all set to 755, but still no joy. Oh, and yes, it was a typo.

I'm really baffled by this :confused:

maimedwabbit
12-23-2007, 02:00 AM
try running it with the -path /your/cod/folder variable. Looks like its just not seeing your bin file for some reason.

Also are your files in the cod4 users home directory? I think the files need to be owned by the user that is running the server. Try to chown the files to the user u are using.

My server is in /home/myuser/cod4 i think it has to be in the users home directory to function properly.

will808
12-23-2007, 02:37 AM
Hi Maimed,


I moved the directory so it was directly under /home/cod4server/ but still no joy - and the same error when I tried running it with -path/to_directory.

I've pasted the contents of the directory below in case that helps:


drwxr-xr-x 6 cod4server cod4server 4096 2007-12-22 11:14 .
drwxr-xr-x 4 cod4server cod4server 4096 2007-12-23 06:32 ..
-rw-r--r-- 1 cod4server cod4server 167936 2007-12-21 20:34 binkw32.dll
-rw-r--r-- 1 cod4server cod4server 216358 2007-12-21 20:34 cod4.ico
-rwxr-xr-x 1 cod4server cod4server 1273 2007-11-18 06:12 cod4_lnxded
-rwxr-xr-x 1 cod4server cod4server 2272028 2007-11-21 20:54 cod4_lnxded-bin
-rw-r--r-- 1 cod4server cod4server 1105976 2007-12-21 20:34 cod.bmp
-rw-r--r-- 1 cod4server cod4server 109976 2007-12-21 20:34 codlogo.bmp
-rw-r--r-- 1 cod4server cod4server 3325952 2007-12-21 20:34 iw3mp.exe
-rw-r--r-- 1 cod4server cod4server 4498779 2007-12-21 20:34 iw3sp.exe
-rwxr-xr-x 1 cod4server cod4server 41384 2007-11-18 06:12 libgcc_s.so.1
-rwxr-xr-x 1 cod4server cod4server 939472 2007-11-18 06:12 libstdc++.so.6
-rw-r--r-- 1 cod4server cod4server 2482 2007-12-21 20:34 localization.txt
drwxr-xr-x 3 cod4server cod4server 4096 2007-12-22 09:22 main
drwxr-xr-x 2 cod4server cod4server 4096 2007-12-21 20:43 miles
drwxr-xr-x 3 cod4server cod4server 4096 2007-12-21 20:43 Mods
-rw-r--r-- 1 cod4server cod4server 434688 2007-12-21 20:43 mss32.dll
-rwxr-xr-x 1 cod4server cod4server 2539230 2007-10-24 09:18 pbsetup.run
-rw-r--r-- 1 cod4server cod4server 6538 2007-12-20 05:03 README.linux
drwxr-xr-x 3 cod4server cod4server 4096 2007-12-21 20:43 zone

will808
12-23-2007, 03:14 AM
OK guys, I have some news - the box I was trying to run the server on has an AMD64 cpu, and it occurred to me that this might have been part of the problem.

So I tried on my Intel laptop and the server fires up fine - very frustrating, but at least I have a pointer for where the problem lies. Does anyone know how to get it to run on AMD64?

maimedwabbit
12-23-2007, 06:34 AM
Its weird it doesnt run on AMD if thats the case. Is your laptop the same linux installation your running on your server?

will808
12-23-2007, 06:56 AM
Yep - Xubuntu 7.10, but the i386 version obviously instead of the amd64 version. I've filed a bug report with icculus but I'm sure there are other people running servers on 64 bit :confused:

Shmio
03-17-2008, 11:46 PM
sudo apt-get install ia32-libs

enjoy...